Autoplay Video Module YouTube Clips on Hover

This post may contain referral links which may earn a commission for this site

The Divi Theme's video module allows you to add (among other things) YouTube clips to your page. If you'd like the videos to start playing when the user hovers over them, you can do so with the following jQuery code:
<script>
jQuery(function($) {
	var video_url;
	$('.et_pb_video iframe').hover(function(){
		$(this).data('src-orig', $(this).attr('src'));
		$(this).attr('src', $(this).data('src-orig')+'&autoplay=1&mute=1');
	}, function(){
		$(this).attr('src', $(this).data('src-orig'));
	});
}); 
</script>
An important point to note is that the video is muted (via the addition of the "mute=1" parameter). This is necessary due to the browser Autoplay policy which prevents unmuted videos from being started automatically (in many cases).

The video will pause / return to the start when the user stops hovering over it.

Hundreds of new features for Divi
in one easy-to-use plugin

2 Comments

  1. Hola, una pregunta, ya añadí el código al head de Divi, pero cuando voy al video de mi página no pasa nada, igual tengo que hacer clic para que empiece a reproducir, debo añadir algo más al módulo de video para que llame al javascript? gracias

    Reply
    • Hi Antony, I just checked on one of my test sites and the code is still working there, so I'm not sure what's causing the issue on your site. I'm not sure where you added the code, but if you haven't already, try adding in using the "Divi > Theme Options > Integration > Add code to the head of your blog" box. Also, try clearing any site caches and your browser cache, then reloading the page. If that doesn't help, is there any chance you're able to send me a link to an example page so that I can take a look? Thanks!

      Reply

Submit a Comment

Your email address will not be published. Required fields are marked *